VMWare Network on Mac OS X x86

How to make your Mac OS X x86 network works with VMWare Workstation???

After Mac OS X has been installed on VMWare Workstation, you will found that the network is not working or the network card it’s not recognize by Mac OS X. You can get the network driver here and follow the instruction below.

Select the ISO file you have downloaded as your CDROM drive

Create a new folder on Desktop(for example network), copy the files from the “CDROM” into the new folder.

Open up the terminal, navigate the to driver folder, run install.sh file and reboot

After reboot, I _think_ your network is working now.(bridge,nat or host also work). Hope it helps. For more information and support please visit the driver’s website

166 Replies to “VMWare Network on Mac OS X x86”

  1. Excellent! v1.0_1043 works like a charm!

    My config:

    DELL POWEREDGE T105 AMD64 OPTERON
    VMWARE WORKSTATION V7.1.3 BUILD 324285
    MAC OSX86 LEOPARD 10.5.4 FOR AMD CPU

  2. i hv a problem….. in the terminal whn i put the command “sudo ./install.sh” it asks me for a password and whn i enter the password it says
    “-k is no longer used; ignoring.
    no work to do; check options and try again.
    usage: kextcache [options] [–] [kext or directory] …
    kextcache -system-mkext [options] [–] [kext or directory] …
    kextcache -prelinked-kernel [options] [–] [kext or directory]
    kextcache -system-prelinked-kernel
    kextcache [options] -prelinked-kernel
    kextcache -update-volume [options]
    kextcache -system-caches [options]
    use kextcache -help for an explanation of each option”

    wat to do now.. pls help…
    and also i dont hv sound in os

  3. Thank you! …. I’m up and running with VMWare 7 and OSX 10.4…. One note… It did not “activate” my network until I went into system preferences -> network….. A dialog popped up telling me it detected a new network interface and to check the settings….. I changed nothing… Clicked apply, and everything started working…. Just an FYI for any other mac illiterates out there.

    Eternal peace & love
    -D

  4. Hello,

    for me this is not helping.
    i use VM Ware Server 1.0.10

    can this be caused of that i do not use WorkStation but Server?

Comments are closed.